NetworkTalk & BGP

A.8.b) Configuration sample

  • Notice that you need to add static routes between the links so load-sharing can be done through the loopback interface.
    We need to add an additional hop for the Ebgp session; this is because the Ebgp session is established to the loopback interface of your neighbor who is one step below the physicals interfaces.
    For that we will need to specify the “ebgp-multihop 2” instruction.
    The number of hops is 2 here, but can be more. It is not important if the number is higher than the minimum requirement, however the contrary will fail the session.

router bgp 1000
neighbor 30.30.30.127 remote-as 400
neighbor 30.30.30.127 description 3xSTM4-ISP-C
neighbor 30.30.30.127 ebgp-multihop 2
neighbor 30.30.30.127 update-source Loopback0
neighbor 30.30.30.127 version 4
address-family ipv4
neighbor 30.30.30.127 activate
neighbor 30.30.30.127 send-community both
neighbor 30.30.30.127 route-map AS-400-INCOMING in
neighbor 30.30.30.127 route-map AS-400-OUTGOING out

ip route 30.30.30.127 255.255.255.255 POS1/1/2 30.30.31.25 name Loopback-Peer-AS400
ip route 30.30.30.127 255.255.255.255 POS1/1/1 30.30.31.21 name Loopback-Peer-AS400
ip route 30.30.30.127 255.255.255.255 POS1/1/3 30.30.31.29 name Loopback-Peer-AS400

route-map AS-400-INCOMING permit 10
match as-path 1
set local preference 90

route-map AS-400-OUTGOING permit 20
match as-path 2
set community 400:70

ip as-path access-list 1 permit ^400_
ip as-path access-list 2 permit ^$

top

Come back to Tutorial Index”

Advertisements